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Getting started with STM32CubeH7 for STM32H7 Series

Introduction

STMCube™ is an STMicroelectronics original initiative to make developers’ lives easier by 
reducing development effort, time and cost. STM32Cube covers the whole STM32 portfolio.

The STM32Cube Version 1.x includes:

• STM32CubeMX, a graphical software configuration tool that allows the generation of C 
initialization code using graphical wizards

• A comprehensive embedded software platform, delivered per series (such as 
STM32CubeH7 for STM32H7 Series)

– The STM32Cube HAL, STM32 abstraction layer embedded software ensuring 
maximized portability across the STM32 portfolio

– A consistent set of middleware components such as RTOS, USB, TCP/IP and 
graphics

– All embedded software utilities, delivered with a full set of examples.

This user manual describes how to get started with the STM32CubeH7 firmware package. 
Section 1 describes the main features of the STM32CubeH7 firmware, part of the 
STMCube™ initiative.

Section 2 and Section 3 provide an overview of the STM32CubeH7 architecture and 
firmware package structure.  

www.st.com

http://www.st.com
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1 STM32CubeH7 main features

STM32CubeH7 gathers together, in a single package, all the generic embedded software 
components required to develop an application on STM32H7 microcontrollers. In line with 
the STMCube™ initiative, this set of components is highly portable, not only within the 
STM32H7 Series but also to other STM32 Series.

STM32CubeH7 is fully compatible with STM32CubeMX code generator that allows the user 
to generate initialization code. The package includes the hardware abstraction layer (HAL) 
APIs that cover the microcontroller hardware, together with an extensive set of examples 
running on STMicroelectronics boards. The HAL APIs are available in an open-source BSD 
license for user convenience.

The STM32CubeH7 package also contains a set of middleware components with the 
corresponding examples. They come with very permissive license terms:

• Full USB Host and Device stack supporting many classes:

– Host Classes: HID, MSC, CDC, Audio, MTP

– Device Classes: HID, MSC, CDC, Audio, DFU

• Graphics:

– STemWin, a professional graphical stack solution available in binary format and 
based on the emWin solution from ST's partner SEGGER

– LibJPEG, an open source implementation on STM32 for JPEG images encoding 
and decoding.

• CMSIS-RTOS implementation with FreeRTOS open source solution

• FAT File system based on open source FatFS solution

• TCP/IP stack based on open source LwIP solution

• SSL/TLS secure layer based on open source mbedTLS

A demonstration implementing all these middleware components is also provided in the 
STM32CubeH7 package.
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Figure 1. STM32CubeH7 firmware components
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2 STM32CubeH7 architecture overview

The STM32CubeH7 firmware solution is built around three independent levels that can 
easily interact with each other as described in Figure 2.

Figure 2. STM32CubeH7 firmware architecture

2.1 Level 0

This level is divided into three sub-layers: 

• Board Support Package (BSP)

• Hardware Abstraction Layer (HAL)

• Basic peripheral usage examples
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2.1.1 Board Support Package (BSP)

This layer offers a set of APIs relative to the hardware components in the hardware boards 
(Audio codec, I/O expander, Touchscreen, SRAM driver, LCD drivers. etc…). It is composed 
of two parts:

• Component

This is the driver related to the external device on the board and not related to the 
STM32, the component driver provides specific APIs to the BSP driver external 
components and can be ported to any board.

• BSP driver

It allows linking the component driver to a specific board and provides a set of user-
friendly APIs. The API naming rule is BSP_FUNCT_Action(): ex. 
BSP_LED_Init(),BSP_LED_On()

The BSP is based on a modular architecture allowing an easy porting on any hardware by 
just implementing the low level routines.

2.1.2 Hardware Abstraction Layer (HAL)

The HAL layer provides the low level drivers and the hardware interfacing methods to 
interact with the upper layers (application, libraries and stacks). It provides generic, multi 
instance and function-oriented APIs which simplify the user application implementation by 
providing ready-to-use processes. As example, for the communication peripherals (I2S, 
UART…), it includes APIs allowing to initialize and configure the peripheral, manage data 
transfer based on polling, interrupt or DMA process, and handle communication errors that 
may raise during communication. The HAL Drivers APIs are split in two categories:

• Generic APIs which provide common and generic functions to all the STM32 Series

• Extension APIs which provide specific and customized functions for a specific family or 
a specific part number.

2.1.3 Basic peripheral usage examples

This layer contains the examples of the basic operation of the STM32H7 peripherals using 
either the HAL APIs as well as the BSP resources.

2.2 Level 1

This level is divided into two sub-layers: 

2.2.1 Middleware components

Middleware components are a set of libraries covering USB Host and Device Libraries, 
STemWin, LibJPEG, FreeRTOS, FatFS, LwIP, and mbedTLS. Horizontal interactions 
between the components of this layer are performed directly by calling the feature APIs 
while the vertical interaction with the low level drivers is done through specific callbacks and 
static macros implemented in the library system call interface. As example, the FatFs 
implements the disk I/O driver to access microSD drive or the USB Mass Storage Class.



DocID030530 Rev 2 9/22

UM2204 STM32CubeH7 architecture overview

21

The main features of each middleware component are as follows:

• USB Host and Device Libraries

– Several USB classes supported (Mass-Storage, HID, CDC, DFU, AUDIO, MTP)

– Support of multipacket transfer features: allows sending big amounts of data 
without splitting them into max packet size transfers.

– Use of configuration files to change the core and the library configuration without 
changing the library code (read-only).

– 32-bit aligned data structures to handle DMA-based transfer in High-speed 
modes.

– Support of multi USB OTG core instances from user level through configuration 
file (that allows an operation with more than one USB host/device peripheral).

– RTOS and Standalone operation

– The link with low-level driver through an abstraction layer using the configuration 
file to avoid any dependency between the Library and the low-level drivers.

• STemWin Graphical stack

– Professional grade solution for GUI development based on Segger’s emWin 
solution

– Optimized display drivers

– Software tools for code generation and bitmap editing (STemWin Builder…)

• LibJPEG

– Open source standard 

– C implementation for JPEG image encoding and decoding. 

• FreeRTOS

– Open source standard

– CMSIS compatibility layer

– Tickless operation during low-power mode

– Integration with all STM32Cube middleware modules

• FAT File system

– FATFS FAT open source library

– Long file name support

– Dynamic multi-drive support

– RTOS and standalone operation 

– Examples with microSD and USB host mass-storage class

• LwIP TCP/IP stack

– Open source standard

– RTOS and standalone operation

2.2.2 Examples based on the middleware components

Each middleware component comes with one or more examples (called also Applications) 
showing how to use it. Integration examples that use several middleware components are 
provided as well. 



STM32CubeH7 architecture overview UM2204

10/22 DocID030530 Rev 2

2.3 Level 2

This level is composed of a single layer which is a global real-time and graphical 
demonstration based on the middleware service layer, the low level abstraction layer and 
the basic peripheral usage applications for board-based features.
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3 STM32CubeH7 firmware package overview

3.1 Supported STM32H7 Series devices and hardware

STM32Cube offers a highly portable Hardware Abstraction Layer (HAL) built around a 
generic and modular architecture. It allows the upper layers, the middleware and 
application, to implement its functions without knowing, in-depth, the MCU used. This 
improves the library code re-usability and guarantees an easy portability from one device to 
another.

The STM32CubeH7 offers a full support for all the STM32H7 Series devices. The user only 
needs to define the right macro in stm32h7xx.h.

Table 1 lists which macro to define depending on the used STM32H7 Series device. This 
macro can also be defined in the compiler preprocessor.

          

Table 1. Macros for STM32H7 Series 

Macro defined 
in stm32h7xx.h

STM32H7 Series devices

STM32H743xx STM32H743VI, STM32H743ZI, STM32H743II, STM32H743BI, STM32H743XI

STM32H753xx STM32H753VI, STM32H753ZI, STM32H753II, STM32H753BI, STM32H753XI
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STM32CubeH7 features a rich set of examples and demonstrations at all levels making it 
easy to understand and use any HAL driver and/or middleware components. These 
examples can be run on any of the STMicroelectronics boards as listed in Table 2:

          

The STM32CubeH7 firmware can run on any compatible hardware. Simply update the BSP 
drivers to port the provided examples on the user board if its hardware features are the 
same (LED, LCD display, pushbuttons).

Table 2. Evaluation and Nucleo boards for STM32H7 Series  

Board STM32H7 Series devices supported

STM32H743I_EVAL
STM32H743xx, and STM32H753xx

NUCLEO-H743ZI
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3.2 Firmware package overview

The STM32CubeH7 firmware solution is provided in a single zip package with the structure 
shown in Figure 3.

Figure 3. STM32CubeH7 firmware package structure

For each board, a set of examples are provided with preconfigured projects for EWARM, 
MDK-ARM and SW4STM32 toolchains. 

Figure 4 shows the project structure for the STM32H743I_EVAL board. The structure is 
identical for other boards.
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The examples are classified depending on the STM32Cube level they apply to, and are 
named as follows: 

• Examples in level 0 are called Examples. They use the HAL drivers without any 
middleware component.

• Examples in level 1 are called Applications, that provide typical use cases of each 
middleware component

• Examples in level 2 are called Demonstration, that implement all the HAL, BSP and 
middleware components

A template project is provided to allow to quickly build any firmware application on a given 
board.

All examples have the same structure, 

• \Inc folder that contains all header files

• \Src folder for the sources code

• \EWARM, \MDK-ARM and \SW4STM32 folders contain the preconfigured project for 
each toolchain.

• readme.txt describing the example behavior and the environment required to make it 
work

Table 3 provides the number of examples, applications and demonstrations available for 
each board.

          

Table 3. Number of examples available for each board 

Board Examples Applications Demonstration

STM32H743I_EVAL 130 51 1

NUCLEO-H743ZI 75 6 1
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Figure 4. STM32CubeH7 example overview
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4 Getting started with STM32CubeH7

4.1 Running your first example

This section explains how simple it is to run a first example with STM32CubeH7. It uses as 
an illustration the generation of a simple LED toggling example running on the 
STM32H743I_EVAL board:

1. After downloading the STM32CubeH7 firmware package, unzip it into a directory of 
your choice, make sure not to modify the package structure shown in Figure 3.

2. Browse to \Projects\STM32H743I_EVAL\Examples.

3. Open \GPIO, then the \GPIO_EXTI folder.

4. Open the project with your preferred toolchain.

5. Rebuild all files and load your image into target memory.

6. Run the example: each time you press the Tamper push-button, the LED1 will toggle 
(for more details, refer to the example readme file). 

The following section provides a quick overview on how to open, build and run an 
example with the supported toolchains.

• EWARM

– Under the example folder, open the \EWARM subfolder

– Open the Project.eww workspace(a)

– Rebuild all files: Project->Rebuild all

– Load project image: Project->Debug

– Run program: Debug->Go(F5)

• MDK-ARM

– Under the example folder, open the \MDK-ARM subfolder

– Open the Project.uvproj workspace(a)

– Rebuild all files: Project->Rebuild all target files

– Load project image: Debug->Start/Stop Debug Session

– Run program: Debug->Run (F5)    

• SW4STM32

– Open the SW4STM32 toolchain

– Click on File->Switch Workspace->Other and browse to the SW4STM32 
workspace directory

– Click on File->Import, select General->'Existing Projects into Workspace' and then 
click “Next”. 

– Browse to the SW4STM32 workspace directory, select the project

– Rebuild all project files: Select the project in the “Project explorer” window then 
click on Project->build project menu.

a. The workspace name may change from one example to another.
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4.2 Developing your own application 

This section describes the required steps needed to create your own application using 
STM32CubeH7.

1. Create your project: to create a new project you can either start from the Template 
project provided for each board under \Projects\<STM32xx_xxx>\Templates or from 
any available project under \Projects\<STM32xx_xxx>\Examples or 
\Projects\<STM32xx_xxx>\Applications (<STM32xx_xxx> refers to the board name, ex. 
STM32H743I_EVAL).

The Template project provides an empty main loop function, it is a good starting point to 
get familiar with the project settings for STM32CubeH7. The template has the following 
characteristics: 

a) It contains sources of the HAL, CMSIS and BSP drivers which are the minimum 
required components to develop code for a given board

b) It contains the include paths for all the firmware components

c) It defines the STM32H7 device supported, allowing to have the right configuration 
for the CMSIS and HAL drivers

d) It provides ready-to-use user files preconfigured as follows:

- HAL is initialized 

- SysTick ISR implemented for HAL_Delay() purpose

- System clock is configured with the maximum frequency of the device 

Note: When copying an existing project to another location, make sure to update the include 
paths.

2. Add the necessary middleware to your project (optional): the available middleware 
stacks are: USB Host and Device Libraries, STemWin, LibJPEG, FreeRTOS, FatFS, 
LwIP, and mbedTLS. To find out which source files you need to add to the project files 
list, refer to the documentation provided for each middleware, you may also have a look 
at the applications available under \Projects\STM32xx_xxx\Applications\<MW_Stack> 
(<MW_Stack> refers to the Middleware stack, for example USB_Device) to get a better 
idea of the source files to be added and the include paths.

3. Configure the firmware components: the HAL and middleware components offer a 
set of build time configuration options using macros declared with “#define” in a header 
file. A template configuration file is provided within each component, it has to be copied 
to the project folder (usually the configuration file is named xxx_conf_template.h. The 
word “_template” needs to be removed when copying it to the project folder). The 
configuration file provides enough information to know the effect of each configuration 
option. More detailed information is available in the documentation provided for each 
component.

4. Start the HAL Library: after jumping to the main program, the application code needs 
to call HAL_Init() API to initialize the HAL Library, which does the following:

a) Configure the SysTick to generate an interrupt every 1ms. The SysTick is clocked 
by the HSI (default configuration after reset)

b) Sets NVIC Group Priority to 4

c) Calls the HAL_MspInit() callback function defined in user file 
stm32h7xx_hal_msp.c to do the global low level hardware initialization
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5. Configure the system clock: the system clock configuration is done by calling these 
two APIs

a) HAL_RCC_OscConfig(): configures the internal and/or external oscillators, PLL 
source and factors. The user may select to configure one oscillator or all 
oscillators. The PLL configuration can be skipped if there is no need to run the 
system at high frequency

b) HAL_RCC_ClockConfig(): configures the system clock source, Flash latency and 
AHB and APB prescalers

6. Peripheral initialization

a) Start by writing the peripheral HAL_PPP_MspInit function. For this function, 
proceed as follows:

– Enable the peripheral clock.

– Configure the peripheral GPIOs.

– Configure DMA channel and enable DMA interrupt (if needed). 

– Enable peripheral interrupt (if needed). 

b) Edit the stm32h7xx_it.c to call the required interrupt handlers (peripheral and 
DMA), if needed. 

c) Write process complete callback functions if you plan to use peripheral interrupt or 
DMA. 

d) In your main.c file, initialize the peripheral handle structure, then call the function 
HAL_PPP_Init() to initialize your peripheral. 

7. Develop your application process: at this stage, your system is ready and you can 
start developing your application code. 

a) The HAL provides intuitive and ready-to-use APIs for configuring the peripheral, 
and supports polling, interrupt and DMA programming models, to accommodate 
any application requirements. For more details on how to use each peripheral, 
refer to the rich examples set provided.

b) If your application has some real-time constraints, you can find a large set of 
examples showing how to use FreeRTOS and integrate it with all middleware 
stacks provided in STM32CubeH7, it can be a good starting point for your 
development.

Note: In the default HAL implementation, the SysTick timer is the timebase source. It is used to 
generate interrupts at regular time intervals. If HAL_Delay() is called from peripheral ISR 
process, the SysTick interrupt must have higher priority (numerically lower) than the 
peripheral interrupt. Otherwise, the caller ISR process is blocked. Functions affecting 
timebase configurations are declared as __Weak to make override possible in case of other 
implementations in user file (using a general purpose timer for example or other time 
source). For more details please refer to HAL_TimeBase example.
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4.3 Using STM32CubeMX to generate the initialization C code

An alternative to steps 1 to 6 described in Section 4.2 consists in using the STM32CubeMX 
tool to easily generate code for the initialization of the system, the peripherals and 
middleware (steps 1 to 6 above) through a step-by-step process:

1. Select the STMicroelectronics STM32 microcontroller that matches the required set of 
peripherals.

2. Configure each required embedded software thanks to a pinout-conflict solver, a clock-
tree setting helper, a power consumption calculator, and an utility performing MCU 
peripheral configuration (GPIO, USART...) and middleware stacks (USB, TCP/IP...).

3. Generate the initialization C code based on the configuration selected. This code is 
ready to be used within several development environments. The user code is kept at 
the next code generation.

For more information, please refer to “STM32CubeMX for STM32 configuration and 
initialization C code generation” user manual (UM1718).

4.4 Getting STM32CubeH7 release updates

The STM32CubeH7 firmware package comes with an updater utility: STM32CubeUpdater, 
also available as a menu within STM32CubeMX code generation tool.

The updater solution detects new firmware releases and patches available on www.st.com 
and proposes to download them to the user’s computer.

4.4.1 Installing and running the STM32CubeUpdater program

1. Double-click SetupSTM32CubeUpdater.exe file to launch the installation.

2. Accept the license terms and follow the different installation steps.

3. Upon successful installation, STM32CubeUpdater becomes available as an 
STMicroelectronics program under Program Files and is automatically launched.

The STM32CubeUpdater icon appears in the system tray: 

4. Right-click the updater icon and select Updater Settings to configure the Updater 
connection and to perform manual or automatic checks. For more details on Updater 
configuration, refer to section 3 of the STM32CubeMX User manual (UM1718).
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5 FAQs

What is the license scheme for the STM32CubeH7 firmware?

The HAL is distributed under a non-restrictive BSD (Berkeley Software Distribution) license.

The middleware stacks made by ST (USB Host and Device Libraries, STemWin) come with 
a licensing model allowing easy reuse, provided it runs on an ST device.

The middleware based on well-known open-source solutions (FreeRTOS, FatFs, LwIP and 
mbedTLS) have user-friendly license terms. For more details, refer to the license agreement 
of each middleware.

What boards are supported by the STM32CubeH7 firmware package?

The STM32CubeH7 firmware package provides BSP drivers and ready-to-use examples for 
the following STM32H7 boards: STM32H743I_EVAL and NUCLEO-H743ZI.

Does the HAL take benefit from interrupts or DMA? How can this be 
controlled?

Yes. The HAL supports three API programming models: polling, interrupt and DMA (with or 
without interrupt generation).

Are any examples provided with the ready-to-use toolset projects?

Yes. STM32CubeH7 provides a rich set of examples and applications (around 181 for 
STM32H743I_EVAL). They come with the preconfigured project of several toolsets: IAR, 
Keil and GCC.

How are the product/peripheral specific features managed?

The HAL offers extended APIs, i.e. specific functions as add-ons to the common API to 
support features available on some products/lines only.

How can STM32CubeMX generate code based on embedded software?

STM32CubeMX has a built-in knowledge of STM32 microcontrollers, including their 
peripherals and software. This enables the tool to provide a graphical representation to the 
user and generate *.h/*.c files based on user configuration.

How to get regular updates on the latest STM32CubeH7 firmware releases?

The STM32CubeH7 firmware package comes with an updater utility, STM32CubeUpdater, 
that can be configured for automatic or on-demand checks for new firmware package 
updates (new releases or/and patches).

STM32CubeUpdater is integrated as well within the STM32CubeMX tool. When using this 
tool for STM32H7 configuration and initialization C code generation, the user can benefit 
from STM32CubeMX self-updates as well as STM32CubeH7 firmware package updates.

For more details, refer to Section 4.4.



DocID030530 Rev 2 21/22

UM2204 Revision history

21

6 Revision history

          

Table 4. Document revision history 

Date Revision Changes

26-Apr-2017 1 Initial release.

29-Aug-2017 2
Updated number of applications for both boards in Table 3: Number of 
examples available for each board and Section 5: FAQs.

Updated Figure 4: STM32CubeH7 example overview.



UM2204

22/22 DocID030530 Rev 2

          

IMPORTANT NOTICE – PLEASE READ CAREFULLY

STMicroelectronics NV and its subsidiaries (“ST”) reserve the right to make changes, corrections, enhancements, modifications, and 
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